Alomerry Wu @ alomerry.com

1008 Elevator

Sep 6, 2018 · 1min · 241 ·

Problem

Source: PAT {target="_blank"}

Description

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop. For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification

For each test case, print the total time on a single line.

Sample Input

3 2 3 1

Sample Output

41

Solution

Code

#include <iostream>
#include <algorithm>
#include <vector>
#define MAX_SIZE 105
using namespace std;

int main()
{
    std::ios::sync_with_stdio(false);
    std::cin.tie(0);

    int i, j = 0, n, a, res = 0;
    cin >> n;
    for (i = 0; i < n; i++)
    {
        cin >> a;
        j = a - j;
        j = (j > 0 ? (6 * j) : (4 * (-j)));
        res += (j + 5);
        j = a;
    }
    cout << res << endl;
    return 0;
}
 
 comment..
你认为这篇文章怎么样?
  • 0
  • 0
  • 0
  • 0
  • 0
  • 0
  • 0
评论
  • 按正序
  • 按倒序
  • 按热度
Powered by Waline v3.0.1
Theme by antfu
2018 - Present © Alomerry Wu